
LAB EXERCISE F: Preparing Effective Maps 

[Images and output created with ArcView® software.] 
In this lab you will continue the work from Lab Exercise A where you mapped median income 
distribution among Greater Boston Towns. However, instead of simply putting a thematic map on 
the screen and printing it out, your goal here is to create maps that "tell a story." At the end of the 
lab, you will turn in a printout of two thematic maps. One map will be prepared as part of this 
exercise and the other you will prepare on your own. Plan your time accordingly. Your final product 
should have your name, titles, and the date. The map should also have a scale bar, north arrow and 
descriptive legend titles. If you have time, you can add descriptive labels to the map as well.  
The goal of this exercise is to join a database file to a boundary file, then create thematic maps 
based on Census variables. First think of a few income, education or race characteristics of Boston 

towns that interest you from among the Census variables in the bosdata database file (the data 

dictionary is listed at the end of this exercise). You may be interested in questions about spatial 
patterns such as:  

  Are highly-educated people clustered in one or two areas, or in a ring around Boston? Are 
they in the northern towns rather than in the south?  

  Are the highest-income towns often adjacent to "poor" towns? Rarely? Never?  
  Are African Americans located in only a few areas, or scattered throughout the region?  
  Are racially integrated towns typically near Boston, or in more rural areas?  
  Are there strong concentrations of vacant homes (neither owner nor renter occupied) in 

certain areas?  

You can no doubt think of many more interesting questions as you look at the Census variables; the 
choice is up to you.  

I. Start an ArcView® Project 

Again, to launch ArcView®, click Start, then the Program menu, then ESRI, then CRL ArcView®. 
Wait a moment for it to launch. (For 11.208, we will use "CRL ArcView®", which customizes the 
ArcView® environment for the CRL, and not "ArcView® GIS Version 3.2a", which lacks these 
customizations). When ArcView® first launches, you should see a "Welcome to ArcView® GIS" 
window that prompts you to create or open a new project. Click the Cancel button to make this 
window go away. You will now be looking at the ArcView® GIS window. Within it, the smaller 
window with "Untitled" in the title bar is an empty "project" window. Now open a new View and add 

the shapefile C:\11.208\arcviewfiles\stateplane\bostown.shp (alternate location: 

K:\11.208\arcviewfiles\stateplane\bostown.shp) to the View. Open the View Properties window, 

rename the View to "Lab F" and set the "Map Units" to meters and the "Distance Units" to feet. 
Remember: you need to set the map and distance units in every new view you create. Make a habit 
of doing this immediately after adding the first theme to a new view.  

Click once on the info "i" tool  button located below the File menu. Move the mouse into the 
map and click on a town. As you can see in the "identify results" window, there is information on 
the town name but no census data yet associated with the file. 



 
Identify Results Window  

With your view highlighted, go to the Theme menu and select Table. Now Attributes of 

bostown.shp is added to the project. Confirm this by going to the project window and clicking on 

the "Tables" icon. You may either "Open" a table or double-click on Attributes of bostown.shp to 

see all the data currently associated with bostown. So far we have town names and boundary data 

for Greater Boston Towns. Next we will add Census data.  

II. Adding and Merging Data Tables 

Now go to the project window and highlight "Tables" then click "Add". Find and select bosdata.dbf 

at C:\11.208\data\bosdata.dbf (alternate location: K:\11.208\data\bosdata.dbf). Note that "List 

Files of Type:" should specify dBASE *.dbf. You should have an "Add Table" window like the one 
below then click OK. 

 
Add Table Bosdata Window 

The bosdata.dbf window that pops up displays a variety of Census variables (see data dictionary at 

end of this lab exercise). In order to thematically map these data, you will need to join them to the 

bostown data.  

First, with either table active, select the Edit > Select None command. This command unselects all 
rows and insures that you will join all the records and not just the ones you may have already 

selected. Second, make the non-mappable bostdata.dbf table active and highlight the Code field. 

Next, activate the Attributes of bostown.shp table and highlight the Code field in that table. Now 

choose Table > Join and the bostondata table will disappear -- and be joined in with the Attributes 



of bostown.shp table. If you scroll across Attributes of bostown.shp you will see all the data 

previously in bosdata. 

Attributes Window of "Joined" Bostown.shp and Bosdata.dbf 
Note: Joins are unidirectional. The active table when you complete the join must be the table to 
which you want columns added. If you join the tables in the reverse order (i.e., the wrong window 

was active when you execute the join), the Attributes of bostown table will disappear and you won't 

be able to map the selections from the expanded bosdata table. If this happens to you, select 

Table > Remove All Joins to undo the join, then bring up the tables and try again. Finally, note 
that these joins are temporary and do not affect the tables that are stored on disk. However, any 
joins that were in effect when you saved your project will be restored when you reopen the project 
file in another ArcView® session.  
  

III. Simple Queries and Thematic Mapping 

Now we will experiment with querying the data. Bring the Lab F View window to the front and make 

sure the Bostown theme is still active (by clicking on it once) and visible (click in the checkbox if 

necessary). From the menus, select Theme > Query or click on the hammer tool, . A dialog 
box pops up in which you construct your query. You can type your query manually into the box in 
the bottom left corner of the window, or you can use the tools at the top of the window. Make sure 
the box next to "Update Values" is checked.  
As an example, let's find the towns with median household income in excess of $50,000 per year. In 
the "Fields" list, double-click on Medy. Then single-click on the ">" button. Next, you can type in 
50000 or scroll down "Values" list until you can double-click on 50000. The query entry window 

should now show (Medy > 50000). Click on "New Set" to run the query and to select these block 

groups. Notice that all towns where the median household income is greater than $50,000 are now 
highlighted in yellow -- both on the map and in the table! You may need to scroll up or down in the 
attributes window to see the highlighted records. You can also click the promote-selected 

button, , to elevate the highlighted block groups to the top of the attribute table.  
Now go ahead and choose your own data attributes and construct a query as appropriate to your 
story. Note that your map should be one that expresses the relationship you've seen -- keep this in 
mind when designing your map. Finalize your map and set the pattern, shading and colors so that 
your map is informative. Pay attention to the data ranges you use, so that you do not 
unintentionally "lie with maps." On the other hand, do feel free to choose ranges, colors, etc. to 
underscore the points you are trying to communicate.  



IV. Calculated Expressions and Thematic Mapping 

At this point, add a new View and Add Theme bostown. Suppose we wanted to generate a thematic 

map of the percentage of persons (aged 25 and older) who have less than a high school education. 

The EDUx variables in the Attributes of Bostown table provide the required information (remember 

that going to the Theme menu and clicking on Table brings out the Attributes of Bostown table). 

They indicate the 1990 census counts of persons (aged 25 years and over) with various degress of 
education as follows:  
EDUCATIONAL ATTAINMENT 
(Universe: Persons 25 years and over) 

Column Description 

EDUTOTAL Total Persons 25 years and over 

EDU1 Less than 9th grade 

EDU2 9th to 12th grade, no diploma 

EDU3 High school grad (includes equivalency) 

EDU4 Some college, no degree 

EDU5 Associate's degree 

EDU6 Bachelor's degree 

EDU7 Graduate or professional degree 

From the listing, we see that the desired percentage equals 100 * (EDU1 + EDU2) / EDUTOTAL. 
However, the tables we are using are read-only so we can't edit the tables in order to add a new 
column that computed this percentage. To overcome this problem, we'd like to create (and edit) a 
local copy of the table. Be sure to click on Edit > Select None before saving the new table -- 
otherwise only the selected rows (and columns) will be saved. Highlight (that is open and activate) 

the Attributes of bostown.shp table and choose Table > Properties. Turn the 'visibility' off for all 

but the three needed EDUx fields and the Code identifier for Boston-area towns. When you click 
'OK' the table will show only those four fields. Now, use the File > Export menu option to save only 
these four fields of the table as a dBASE-formatted table in your crlspace. At the Export Format 
window select dBASE. The *.dbf suffix will be a handy reminder of the data format for the table and 
the dBASE format is quite portable and easily read by Excel and many other packages. Call the table 

bostedu.dbf.  

Now add this newly saved bostedu.dbf table into your ArcView® project. (Remember to specify the 

dBASE file type.) Since you now have write access to this table, you will now be able to add a new 
column for computing your low-education percentages. With this new table highlighted, click on 
Table > Start Editing and then on Edit > Add Field. Call the new field p_lowed and accept the 
default data type (numeric), width (16) but change the decimal places to one. Next select Edit > 
Select All (alternatively, if none are selected then all will be selected in this case). Next, choose 
Field > Calculate and add the expression 100 * (EDU1 + EDU2) / EDUTOTAL: 



 
Field Calculator 
Now we're almost there. Click on Table > Stop Editing and save your edits. (Note that you will not 

be able to join the tables until you stop editing the bostedu.dbf table.) 

Again, in order to thematically map these data, you will need to join bostedu.dbf to the bostown 

data. 
First, with either table active, select Edit > Select None from the menus. Second, make the non-

mappable bostedu table active and highlight the Code field. Next, activate the Attributes of 

bostown.shp table and highlight the Code field in that table. Now choose Table > Join and the 

bostedu table will disappear -- and be joined in with the Attributes of bostown.shp table. If you 

scroll across Attributes of bostown.shp you will see all the data previously in bostedu. 

In your View window you can now double-click on Bostown and pop up your Legend Editor. Here 
change the Legend Type to Graduated Color and adjust the classifications. In this example we use 
four ranges to explore the distribution of percentages of persons with less than a high school 
education among Boston towns: 



ArcView® Window with Thematic Map 
Congratulations! You've made map 1. Now generate another thematic map based on related 
variables that might help you tell a story. 
Some suggestions for improving your map:  

  Set the name of your view to something descriptive. The view name becomes the 
default title of your layout when you create it using the View > Layout menu item. To 
change the name, make sure the view window is active, then select View > Properties 
from the menus. You can then change the view name in the View Properties window. 



  Set the name of each theme to something descriptive. The theme name shows up in 
the legend of your map. The default name is often unattractive in a legend (e.g., ends in 
.shp, is abbreviated, etc.). To change the name, choose a theme in the View window by 
clicking on it, then select Theme > Properties from the menus. The Theme Properties 
window will appear. Make sure that the Definition icon on the left side of the window. You 
can then change the contents of the "Theme Name" field.  

   

 

Font Palette Window 

  Add text labels to your map. Text labels often add 
useful information to a map. You can add labels in a 
few different ways. First, however, you should give 
ArcView® some information about how it will create 
labels. Each theme has a label field, which is a column 
from the theme's attribute table that will be used for 
labels. To select the text label field for a theme, select 
the theme, then select Theme > Properties from the 
menus. Make sure that the Text Labels icon is 
selected on the left side of the window. You can then 
change the contents of the "Label Field" item. You can 
also adjust where the label will be placed relative to 
the label point and choose whether or not to scale the 
labels to the scale of the view. You can select the text 
font, size, and style by selecting Window > Show 
Symbol Window. When the Symbol Window appears, 

click on the Font Palette (ABC) button . Now you 
can pick a font (Arial, Times, etc.), size (10, 12, 14 
point, etc.), and style (bold, italic, etc.). 

  With these preliminaries out of the way, you're ready to place 
some labels on the map. 

o Use the Auto Label feature. This is the easiest method, 
but does not always yield the most attractive results. To 
use it, select a theme in your view, then select Theme > 
Auto Label. This choice will label the features in that 
theme with the contents of the pre-defined text label field. 
You have the choice of labelling all the features or just 
those visible in the view. If you're not happy with the 
results, use Theme > Remove Labels to get rid of them.  

o Use the Label button. You can place labels manually 

using the Label tool . This gives you the luxury of 
placing just the labels you want where you want them by 
clicking on the map. Of course, if you have a lot of items 

to label, this could take some time. Note that if you click and hold the Label tool, 
you can select from a variety of label tools (see the image on the left). You can use 
these other label types to make fancier labels such as highway shields or callout 
boxes.  

 

  Label Tools   

o Place Arbitrary Text on the Map. You can use the Text tool to place text on 
the map where you click. Similar to the Label tool, if you click and hold on the tool, 
you can select from a number of text tools. 
   

V. Layout: Working with Multiple Frames 

After you have created the second map, use the Layout window to place your name and both maps 
on a page. Arrange the maps, titles, name(s) and date as necessary and print it out. The map 



should also have a scale bar (i.e., in miles), north arrow and descriptive legend titles. Your final 
product will be judged on both content and presentation, so save time to make the maps good-
looking and effective. 
While in the Layout Window you can add, edit, move, and resize its contents by adjusting the 
associated frames of the views, legends, text, arrow, and scale bars. For example, with the Layout 
window highlighted, you can modify and add north arrow or scale bars. From the Layout button 

bar , click on the arrow pointer button . Then move the mouse 
to the arrow or scale bar and click to select then click and drag to move it. Double-click on the 
arrow or scale bar to change options. Also, by clicking and dragging highlighted corners of their 
frames you can also resize arrows and scale bars. 

Another approach is to click and hold (for a moment) the View Frame button  (or whatever is the 
last button on that bar). You will see a vertical button bar:  

 
Select one of these buttons then move your mouse to where you want to place the item and click 
and drag.  
   

Here you will see the View Frame button :  
This will allow you to add other View frames to your layout  

Here you will see the north arrow icon :  
North arrows are also contained within frames in the layout. You can select among different styles 
of north arrow to place on the layout. You can also choose an angle (in degrees) that the north 
arrow should be rotated.  

Here you will also see the scale bar icon :  
Note that in order to create a scale bar, the view must have its map units defined. Scale bars are 
also contained within frames in the layout. When you create a scale bar frame, it is associated with 
a view frame. If the view frame is live linked, and the scale of the view is changed by zooming in or 
out, the scale bar will update accordingly.  

You will also see the legend icon :  
Legends are also contained within frames in the layout. Legend frames contain a representation of a 
view's Table of Contents. When you create a legend frame, it is associated with a view frame. 
Whichever themes are drawn in the view will be shown in the legend. If the view frame is live 
linked, and a theme is turned on or off, the legend updates accordingly by adding or removing the 
theme symbol and text.  
Remember that ArcView®'s online help also has useful information.  
   
OPTIONAL: If you have completed Lab E, make a thematic map using your database table of 
workers in Middlesex County block groups who drive alone to work. Use the block group map 

C:\11.208\arcviewfiles\stateplane\mablkgrp.shp (alternate location: 

K:\11.208\arcviewfiles\stateplane\mablkgrp.shp).  

Data Dictionary for bosdata.dbf 

You will see the following eight columns in bosdata.dbf for each town: 



TOWNAME The name of the town 

FIPSCODE The Census identifier for the town, unique for the whole country ("Federal 
Information Processing Standard") 

TOTPOP Total population 

WHITE_POP White population 

BLACK_POP Black population 

INDESK_POP Indian/Eskimo population 

ASIAN_POP Asian population 

OTHER_POP All other population not included in the above four groups 

The next eight columns refer to educational attainment. Except for the universe, the data come 
from STF3A table P57.  

EDUTOTAL Universe: Persons 25 years and over 

EDU1 Less than 9th grade 

EDU2 9th to 12th grade, no diploma 

EDU3 High school graduate (includes equivalency) 

EDU4 Some college, no degree 

EDU5 Associate degree 

EDU6 Bachelor's degree 

EDU7 Graduate or professional degree 

The next twenty-six columns refer to household income in 1989. Except for the universe, the 
data come from STF3A table P80.  

HHTOTAL Universe: Households 

HHY1 Less than $5,000 

HHY2 $5,000 to $9,999 

HHY3 $10,000 to $12,499 

HHY4 $12,500 to $14,999 

HHY5 $15,000 to $17,499 

HHY6 $17,500 to $19,999 

HHY7 $20,000 to $22,499 

HHY8 $22,500 to $24,999 

HHY9 $25,000 to $27,499 

HHY10 $27,500 to $29,999 

HHY11 $30,000 to $32,499 

HHY12 $32,500 to $34,999 

HHY13 $35,000 to $37,499 

HHY14 $37,500 to $39,999 

HHY15 $40,000 to $42,499 

HHY16 $42,500 to $44,999 

HHY17 $45,000 to $47,499 



HHY18 $47,500 to $49,999 

HHY19 $50,000 to $54,999 

HHY20 $55,000 to $59,999 

HHY21 $60,000 to $74,999 

HHY22 $75,000 to $99,999 

HHY23 $100,000 to $124,999 

HHY24 $125,000 to $149,999 

HHY25 $150,000 or more 

MEDY Median household income for each town 

TOTALUNITS Total housing units 

OWNER_OCC Owner-occupied housing units 

RENTER_OCC Renter-occupied housing units  
(Note: Due to vacancies, TOTALUNITS will not necessarily be the sum of 
RENTER_OCC plus OWNER_OCC.) 

MED_RENT Median rent for renter-occupied units 

MED_VALUE Median value of owner-occupied housing units 
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