
LAB EXERCISE G: Web Mapping Resources and Basic Spatial Analysis 

 
[Images and output created with ArcView® software.] 
One of the richest sources of planning information is the World Wide Web. As web servers speed up 
and programming improves, interactive mapping and data access have both become easier. Maps 
have a particular appeal, and there are a number of websites that provide address location and 
navigation services. More sophisticated sites allow you to turn data layers on and off, and provide 
the types of information planners tend to be most interested in. For example, the Census map 
shown below (in Part III) shows family income by census tract in the Washington, DC area -- lighter 
green represents less money. Let's begin this exercise by utilizing a MIT web mapping service (run 
at the CRL by DUSP's Planning Support Systems group) to get digital orthophotos that can help 
enhance our ArcView® maps. 

I. Using Digital Orthophotos in ArcView® 

In class, we discussed the MIT OrthoTools project that Dr. John Evans, Tom Grayson, and others 
worked on with Prof. Ferreira. (Orthophotos are aerial or satellite photos that have been adjusted to 
account for the curvature of the Earth and the camera's distortion and projected to a standard, 
geographically referenced coordinate system.) We have also shown you metro Boston orthophotos 
on the MIT/MassGIS Digital Orthophoto web site and demonstrated pulling snippets of these orthos 
into ArcView® map views. Now you will get the chance to experiment with this functionality 
yourself. In this assignment you will use orthophotos to create a detailed map. 

 
A Portion of a Digital Orthophoto of MIT  
Launch ArcView® in the normal fashion. When ArcView® first launches, you should see a "Welcome 
to ArcView® GIS" window that prompts you to create or open a new project. Click the Cancel 
button to make this window go away. Next, open a new View window and use View > Add Theme 
to open a file containing Cambridge landuse use information. The file is: 

C:\11.208\arcviewfiles\stateplane\landuse85 (alternate location: 

K:\11.208\arcviewfiles\stateplane\landuse85). Click on the small grey box  

to display this theme and make it active.  
The geography for this theme is stored in Massachusetts State Plane coordinates (NAD 1983, 
meters). Let ArcView® know this by using the View > Properties dialogue box to set the Map 
Units to meters and Distance Units to feet.  
To facilitate bringing orthos into ArcView®, one Research Assistant on the MIT OrthoTools research 
team (Nadine Alameh) built an ArcView® extension. You can add this ArcView® enhancement, 
called 'MITOrtho Extension', by choosing File > Extensions from the File menu. The Extensions 
window will appear. Notice how many extensions there are. Some of these come with ArcView®, 
while others are obtained separately, either by purchase or download. 

http://ortho.mit.edu/


 
Extensions Window  
To enable the MITOrtho Extension, you must check the box to the left of its entry in the list. It is not 
enough to click on the name; all this does is display a brief description in the "About:" box, as 
shown above. After checking the box, click OK.  
Double-click on the Views icon and you will see that if you loaded the extension successfully, two 

new buttons will appear in your view toolbar: The Pick Server button  and the Get Ortho 

button   First, click on the Pick Server button . The 'Pick an orthophoto set' dialog box will 
appear. Click on "Boston metro area orthophotos" and then click 'OK'. Note that other orthophoto 
sets are also available, including the Massachusetts coast orthophotos, which, unlike the Boston 

metro orthos, are in color! Then click on the Get Ortho button . After a delay of a few seconds, 
an orthophoto should be slipped underneath the Cambridge landuse map that is displayed in your 
View window. Zoom out to confirm that the image is only as large as needed to fill the view window 
(when you clicked the 'ortho button'). The result should look something like this: 

 
View Window of Landuse and Orthophoto  



Of course, as you can see, the shading of the landuse85 theme covers up part of the orthophoto. 
Let's make the shading of the landuse85 theme semi-transparent so that the orthophoto shows 
through. To do this, we can change the symbol shading properties of the landuse85 theme. Double-

click inside the landuse theme legend entry   to open the Legend Editor 
and then double-click on the color symbol box to open the palette dialogue boxes. 

 
Legend Editor Window  
Change the fill palette patterns from the solid second box to one of the others further down the 
list. Then switch to the color palette (by clicking the paintbrush button) and change the Color: 
Foreground to Background color to transparent (note that you may first need to click outside then 

inside the  transparency box in order to turn transparency on). Now click Apply on the Legend 
Editor window and notice that the landuse85 theme will be partially transparent and the ortho will 
show through to some extent. 
Since we have landuse information stored in the landuse85 theme, we can shade the Cambridge 
map based on land use and set the colors and patterns so that the ortho will still show through. To 
help you interpret the landuse codes, we've stored a lookup table that explains what each code 
means. Load this lookup table by clicking the Load button on the Legend Editor window and 

selecting the landuse.avl file in the C:\11.208\arcviewfiles\stateplane directory. At the Load 

Legend window, click OK.  
At the Legend Editor window that pops up, you now see different symbol color associated with 
different categories of land use types. If you click Apply you see that that the solid colors obscure 
the ortho photo. Now double-click on each symbol color box and adjusting the colors, patterns, and 
degree of transparency of each landuse value so that the Cambridge landuses are readable without 
completing obscuring the ortho. Follow similar steps to one you used just a moment ago to change 
the fill palette and color palette to turn transparency on. 



Zoom in on a few commercial and residential areas and see how well the identified land 
uses appear to match the buildings and other features in the digital ortho. Note that 

you'll need to refresh your ortho snippet (by clicking the Ortho button  ) in order to 
get higher resolution images once you have zoomed in. Find what appears to be a 
commercial strip (e.g., along parts of Mass Ave!). Zoom in to the area, set the 
transparencies so buildings are identifiable and use the graphics editing tools in 
ArcView®. The graphics editing tools are usually found by clicking (and holding down) 

the button to the right of the Text button . These tools offer several graphics choices:  

 

Graphics 
Tools 

For example, using the Polygon Draw tool  you can create a polygon shape that 
traces the building footprint of one of the larger buildings in your commercial area. Click 
once to start a segment and click again to end that segment and so on. Double-click to 
finish the polygon. You can use this technique to do 'heads up' digitizing on top of an 
orthophoto. Since the ortho has meaningful geographic coordinates, you can then convert 
the graphic to a shapefile, tag features with appropriate IDs, and link them to other data 
about the building, road centerline, pond, or other feature that you just digitized. We 
don't have time to explore these capabilities further in this exercise. 
Print out a single map containing two views -- one showing all of Cambridge, the other a 
zoomed in view of your commercial area with the outline of a building or other feature 
clearly visible using the graphic tools just mentioned. Be sure you've adjusted the color, line 
weight, etc. of the vector map layers so they are clearly visible on top of the image and they don't 
obscure the image entirely.  
OPTIONAL, but fun:  

Try adding more Cambridge themes from the K:\\11.520\data directory as shown in the image 

below. 



 
Orthophoto with 11.520 Themes  

II. Select by Theme: A Quick Form of Point-in-Polygon Analysis 

The real power of GIS comes from its spatial analysis tools. These include the ability to query the 
data not just on the attributes of the themes, as we've done so far in labs, but using the geography 
of the points, polygons, and lines. One of the most basic spatial analysis operations is to identify the 
points that fall within one or more polygons. This is sometimes called a polygon overlay operation. 
ArcView® makes this easy with a feature called "Select by Theme." Let's try it now, by looking for 
block groups where housing sales occurred. 
Open a new view for this part of the lab. Add these themes to this view: 

  K:\11.208\arcviewfiles\stateplane\cambridge_sales_1989.shp 
(location of all (1-4 family) residential homes in Cambridge, MA that sold during 1989, as 
reported by Banker and Tradesman, 1987-89)  

  K:\11.208\arcviewfiles\stateplane\cambridge_block_groups.shp 
(1990 U.S. Census block groups for Cambridge, MA)  

Make sure that the sales display on top of the block groups and that you set the map units to 
meters and distance units to miles using Theme > Properties. 
1. Let's identify the block groups where any sale occurred: 



  Click once on the Cambridge_block_groups.shp theme to make it active  

  Select Select by Theme from the Theme menu  
  Select features of active themes that "Intersect" the selected features of 

Cambridge_sales_1989.shp  

  Click the "New Set" button  

The block groups where sales occurred should now be highlighted! 
2. Now let's try a slight variation on the previous query. This time, we'll find the block groups where 
low-priced sales occurred, defined by a sale price of under $150,000: 

  Click once on the Cambridge_block_groups.shp theme to make it active  

  Select Theme > Clear Selected Features to clear the selected block groups  

  Click once on the Cambridge_sales_1989.shp theme to make it active  

  Use the Query ("hammer" ) tool, , to select those sales with a Realprice less than 
$150,000. You should find that 29 of the 222 sales meet this criterion.  

  Now select the areas of the city (block groups) where these sales occurred by repeating the 
steps of Query 1.  

This time you should see significantly fewer highlighted block groups. By the way, because 
ArcView® highlights the sales and block groups in the same color, you won't be able to see most of 
the highlighted sales unless you change the marker symbol for the sales to something with a black 
outline. Try this now. 
Among the capabilities available to you now would be to compare the characteristics of the block 
groups based on the sale price of the houses. We won't ask you to do this for this lab, but we invite 

you to consider how you would approach that question. The cambridge_block_groups.shp theme 

has many variables you could analyze. 

III. Simple Buffering 

The "Select By Theme" operations in the previous section involved asking which set of spatial 
features (sales) were completely contained within another set (block groups). Another basic spatial 
analysis operation is to determine which spatial features and close to other spatial features. 
Buffering tools are one way to do this.  
Suppose we wanted to check whether the lower-priced housing tended to be closer to the major 
roads. Let's use ArcView®'s buffering tools to create a buffer around Massachusetts Ave. and see 
whether the sales in the buffer are relatively high or low priced.  
First, clear the selected features of the sales and block groups. Add the shapefile 

K:\11.208\arcviewfiles\stateplane\cambridge_tiger.shp to your ArcView® project. This the TIGER 

file for Cambridge, which includes streets, railroads, geographic boundaries, and hydrography. Now 

use the Query ("hammer") tool, , to select only those road links where 
( [Fname] = "Massachusetts" ) or ( [Fname] = "State Hwy 2A" ) 
Your query condition in the query window should look like the one above. You should end up with 
both the arcs named "Massachusetts" and "State Hwy 2A". There is one street link on the Mass. 
Ave. bridge that has [Fname] = "Masssachusetts Ave"! Don't bother including that link. Note 
that the TIGER file is inconsistent about the name it uses for Massachusetts Ave. The 
Commonwealth of Massachusetts designates this part of Massachusetts Ave. as State Highway 2A, 
and you can spot some signs along the street that indicate this fact. The TIGER file switches back 
and forth between these two names. This is a good example of a problem that you may encounter 
in real world data! 
Now highlight this theme in the View window legend and choose the Theme > Create Buffers 
option. In the create buffers window, choose these options: 

  Buffer the features of the theme Cambridge_tiger.shp  



  Use only the selected features (There should be 108 of these; if your count differs, cancel 
this operation and redo your query.)  

Click on the Next >> button to continue. On the second screen, indicate that you want to create 
buffers at a specified distance of 0.5 miles. Check the distance units to make sure they are correct. 
Click on the Next >> button to continue. On the third screen, check 'Yes' where you are asked 
about dissolving the barriers between buffers and save the results in a new theme: 

H:\private\massbuf.shp. When you've adjusted all these settings, click "Finish" and wait for 

ArcView® to do the computations. You should end up with a curved sausage-shaped area 
something like the one in the image entitled "Massachusetts Avenue Buffer" below.  

 

Massachusetts Avenue Buffer 

Since this newly created buffer is an ArcView® shapefile, we can use it just like any other theme. In 
particular, we can do an exercise similar to "point-in-polygon" example we just did in order to 
determine which 1989 housing sales are located within uor new buffer. Highlight the 

Cambridge_sales_1989.shp theme (with all the sales not just the low-priced ones) and choose 

Theme > Select by Theme. Select all the Cambridge_sales_1989.shp cases that intersect the 

Buffer 1.00 of Cambridge_tiger.shp theme. You should find that 141 of the 222 sales are located 

within the half-mile buffer. 
ArcView® will easily let us calculate some summary statistics on the sales we just identified. To do 
so, 

  Click once on the Cambridge_sales_1989.shp theme to make it active  

  Select the column heading for Realprice  
  Choose Field > Statistics from the menus.  

What are the mean and standard deviation of sale prices for the sales within the buffer? Write 
down these the values on the assignment sheet. 
Now use Edit > Switch Selection. The records that were previously selected are now unselected 
and vice versa. Now you can compute the statistics for the sales outside the buffer. Write down 
these the values on the assignment sheet. 
The sales prices in and out of the buffer aren't all that different (compared with their standard 
deviation), and parts of the buffer fall outside Cambridge. Before reaching any conclusions, we 
would want to do further analysis. However, this quick tour of spatial selection is enough for today. 
If you elect to take the full-semester GIS subject 11.520, you'll examine lots more of the spatial 
analysis capabilities of ArcView®.  

http://crl.mit.edu/classes/11.520


IV. OPTIONAL: Exporting Maps from ArcView® 

For a number of reasons you might want to do something with your map other than print it from 
ArcView®. You may want to create a JPEG or PDF file for use on the web or just get the map into a 
graphics program to add some finishing touches. Here we consider these two popular formats.  
PDF format: Files in this format can be read using a free program called Acrobat Reader. This 
program comes in a standalone version and as a web browser plugin. The benefit of this format 
over a JPEG and other bitmap formats is that it's resolution independent. You can zoom in and out 
of the map and print it at any scale. On many PC's at the CRL you should be able to print directly to 
PDF. When printing, look for the printers called "Acrobat Distiller" and "Acrobat PDFWriter." 
PDFWriter is simpler to use, but not as powerful as Distiller. You can try PDFWriter first and see if it 
suits your needs. If not, try Distiller. 
Additionally, Tom Grayson has written some notes about how to create PDF files of ArcView® maps. 
It's done most easily on Athena workstations and involves too many steps to squeeze into this 
exercise. However, you may find the notes helpful in the future. Basically, you create a PostScript 
file of your ArcView® layout by using the "Print to File" option when printing to a PostScript printer 
(which the CRL's and Athena's printers are).. Then you use a tool like Acrobat Distiller to convert 
the PostScript file into the PDF format. In ArcView®, select File > Export, choose the "PostScript 
New" option for file type, and save the file with a ".ps" extension (e.g., mymap.ps). Athena has a 
site license for the 'distiller' on Athena, you can save the PostScript file on your 'crlspace' and then 
log onto an Athena Sun to access the file and distill it. 
JPEG format: Creating JPEG images is much easier than PDFs because the JPEG format is natively 
supported by ArcView®. In ArcView®, use File > Export, select the "JPEG" option for file type, and 
save the file with a ".jpg" extension (e.g., mymap.jpg). You can view your JPEG file easily with 
Netscape; select File > Open Page, click on the Choose File button to navigate to the file, then 
click on the Open in Navigator button. In their favor, JPEG's are compact and nearly universally 
readable. Unfortunately, they use "lossy" compression, meaning that a JPEG image is not fully 
faithful to the original. Artifacts caused by the lossy compression are often visible in JPEG versions 
of maps. ArcView® does a particularly poor job of generating JPEG files, and you may prefer to 
create higher quality images using PostScript files. Finally, like any bitmap format, JPEG's have a 
fixed resolution, limiting the ability to zoom in effectively. JPEG's are useful for overview graphics on 
web pages, while PDF's can be used to supply the full detail. 

V. Browsing Map-Related Web Sites 

The following sites specialize in maps and interactive mapping on the Web. Browse through them 
and try out their programs. Are they flexible enough to be useful? Do they have the type of data 
that you might use for your research? What other types of spatial information would you want to 
have access to? Just think about this questions -- you do NOT need to write down your answers and 
turn them in.  

http://www.mapquest.com/  http://tiger.census.gov/  Other Map-Related Sites  

  

USGS Earth Explorer  

Harvard Geospatial Library  

Geography Network  

Massachusetts Electronic Atlas 

While there has been an explosion on spatial data over the past several years it isn't always free or 
conveniently located on the Net. Often, local governments and planning boards decide to invest in 
such data but don't publicize its availability. That doesn't mean that what you want doesn't exist, 
but you may have to be creative in thinking who might have such data and how they might be 
convinced to let you have access to it. Rotch Library also has a number of electronic data sources 
(including Census geography) which may be helpful.  

http://www.adobe.com/products/acrobat/readermain.html
http://gis.mit.edu/classes/11.520/pdf_tips.html
http://www.mapquest.com/
http://tiger.census.gov/
http://earthexplorer.usgs.gov/
http://hgl.harvard.edu/jsps/basemap.jsp
http://www.geographynetwork.com/
http://hcl.harvard.edu/maps/massatlas.html
http://libraries.mit.edu/rotch/
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