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GIS Level 2 

MIT GIS Services: libguides.mit.edu/gis 

Introduction 
Covered in this workshop are a range of tools that are useful in a variety of applications and disciplines. 
This exercise will be partly performed using the ModelBuilder tool in ESRI ArcGIS which allows users to 
develop a workflow of their methodology. This workflow can be saved and shared on different machines 
and with other users so that a process that would normally comprise multiple steps is collapsed into one 
tool. 
 
Tools this workshop covers include:  

 Definition Queries 

 Create a new field in the attribute table and use the Field Calculator to create an expression 

 Add XY Data and Projections 

 ModelBuilder and Clip, Buffer, and Intersect 

 Dissolve 

 Select by Location and Select by Attributes 

 Spatial Join 

 Create and Edit Features 

 Save your ArcMap project and package it  

 Optional bonus exercise: Geocoding with QGIS 

Getting Started 

Moving Data to your Computer 
1. Create a folder on your desktop and name it your last name. 
2. Download the example data.  

  

libguides.mit.edu/gis


GIS Level 2 Workshop, MIT GIS Services   2 
 

Starting ModelBuilder 
1. Start a new map in ArcMap (Start > All Programs > ArcGIS > 

ArcMap) 
2. If the ArcCatalog window is not already open, click the 

ArcCatalog button ( ) or Windows > Catalog. Expand the 
Toolboxes menu, right click on My Toolboxes, and select 
New > Toolbox. Since we are creating one tool for all the 
steps in this exercise, you can name the tool GIS Level 2.tbx. 

3. Right click on GIS Level 2.tbx and click New > Model.  
4. If your new model opens automatically, close it for now. We’ll come back to ModelBuilder later 

on. 
5. Change the name of your new model to GIS Level 2 by right clicking on it and selecting rename. 

Add Data 
GIS is commonly used for site selection analysis. In this exercise we will use tools to select a site for a 
new apartment building in New York City.  

 
Much of the data used in this workshop is available for download on the MIT Geodata Repository 
(http://arrowsmith.mit.edu/mitogp) We are also going to use some zoning data from the New York City 
Department of City Planning website. To save time we have already downloaded this free data and 
placed it the folder that you’ve copied onto your desktop. 

1. Click the Add Data button ( ) in ArcMap. 
2. Navigate to your folder on the desktop. If you don’t see your folder as one of your folder 

connections, use the Connect to Folder ( ) button to browse for and access it. 
3. Add US_NY_NYC_MN_G47TXLOTS_2011.shp, US_NY_NYC_E68SCHOOLDIST_2005.shp, 

US_NY_NYC_F7BOROBNDRYS_2005.shp and nyzd.shp from that folder to your map (you can 
select more than one file at a time by holding the Ctrl button. These shapefiles represent 
Manhattan tax lot boundaries, New York City school district boundaries, New York City borough 
boundaries, and New York City zoning data, respectively. 

 
Now that you’ve added your data to your map, take the time to save your map document in your 
working directory (File Save As). Whenever working in GIS, make sure to save early and often. 

Definition Queries 
A definition query is a way of displaying and interacting with a subset of a layer based on an expression. 
It is very similar to a selection by attributes, with the difference being that the result is a change in 
display in the table and map rather than a selection. Like a selection, a definition query makes no 
permanent changes to your underlying data nor does it create a new layer. 

1. We want to find vacant land for our apartment building.  Vacant land is a land use category used 
by the planning department.  

2. Every data layer in the MIT Geodata Repository (and typically GIS data from other sources as 
well) includes metadata. Metadata provides information about the data layer such as what any 
attributes and codes mean, who created the file and when, information to use when you cite 
the data, and whether there are use constraints for the file.  To explore the metadata for the tax 
lots file, you can navigate to this direct link: 

http://arrowsmith.mit.edu/mitogp
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https://arrowsmith.mit.edu/mitogp/layer/MIT.SDE_DATA.US_NY_NYC_MN_G47TXLOTS_2011/ . 
If you scroll down and expand the entity and attribute information section, you will find in this 
metadata that a land use (LANDUSE) value of 11 represents vacant land.  
 

You can also (optionally) review a copy of the metadata using ArcMap. To do this, you first need to 
navigate to Customize > ArcMap Options > Metadata and select FGDC CSDGM Metadata from the 
dropdown menu to enable that metadata style. Click Ok. Then, right click on the layer > Data > View 
Item Description to see the metadata. Descriptions of attributes (e.g. land uses) are located under FGDC 
Metadata > Entities and Attributes. 
 

1. Move your tax lot layer (the layer with g47txlots in the name) to the top of the drawing order 
(click and drag in the Table of Contents). If you are unable to drag, switch to List by Drawing 
Order ( ) at the top of the Table of Contents. 

2. Double click on the layer name of your tax lots to 
open the layer properties and click on the 
Definition Query tab > Query Builder. 

3. Double click on LANDUSE in the list of fields. The 
field name will be added to the expression below. 

4. Add an equal sign (=) to the expression. 
5. Now click on Get Unique Values and double click 

11 to add this to the expression. 
6. Click OK > OK. As you can see, the only parcels that 

remain are ones that are currently vacant. If you 
have trouble seeing the remaining parcels, double 
click on the color under the layer name and choose 
a brighter color, such as yellow. 

7. Using the same process, restrict the boroughs to 
Manhattan (layer with f7borobndrys in the name) 
using the field name BORONAME. 

 

 

Through research you’ve decided School District 3 should be excluded from 
the areas of consideration for your site selection.  

8. Using the same process, restrict the school districts layer (layer with 
e68schooldist in the name) to anything but (<>) School District 
(SCHOOLDIST) 3. The expression should look like SCHOOLDIST <> ‘3’ 

  

https://arrowsmith.mit.edu/mitogp/layer/MIT.SDE_DATA.US_NY_NYC_MN_G47TXLOTS_2011/
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Create a new field in the attribute table and use the Field Calculator to 

create an expression 
We also want to restrict to areas that have been zoned for residential use. If you open the attribute 
table (right click data layer nyzd), you’ll notice that ZONEDIST gives information on zoning that is too 
specific for our purposes. We just want to know the first letter (R = residential). 
 

1. Click the drop down menu for the table and click Add Field… Name the field ZONECAT and 
specify it as type text.  Click Ok. 

2. We want ZONECAT to contain the first letter of ZONEDIST. Right click the field name ZONECAT 
and select the Field Calculator. Click Yes when asked if you want to calculate outside of an edit 
session.  

3. Change Type to String. Double click on Left() in the Functions menu. 
4. Move your cursor in between the parentheses and double click on ZONEDIST in the Fields menu. 

Then type: , 1 to specify that you want to keep one character from the left. 
5. Your expression should look like this: 

Left ([ZONEDIST], 1) 

6. Click Ok. Now you can run a definition query where ZONECAT is R. Once you have set up the 
definition query, close the table. 

Add XY Data and Projections 
ArcGIS is also able to display points based on X and Y fields in a table. In our site selection, we want to 
incorporate the location of subway stations in New York, but we only have a table of where the stations 
are. 
 

1. Add StationEntrances.csv to your map using the Add Data button. This file is in the folder on 
your desktop. 
 

ArcGIS can read and analyze CSV tables, but its favorite tabular format is DBF (also called dBASE). We’re 
going to need to make some alterations to this table, 
so we want it to be in DBF format. 
 

1. Right click on the table and point to Data > 
Export.  

2. Save the table in your folder on the desktop 
by clicking the folder icon next to Output 
Location box.  

3. Name your file stations.dbf. Select dBASE 
Table from the Save as type drop down 
menu.  

4. Click Save > OK, and select Yes when asked if 
you want to add the table to your map. 

5. Remove StationEntrances.csv by right clicking 
and selecting Remove. 

6. Open the table by right clicking on the 
stations layer and note that there are fields 
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for the latitude and longitude of the subway station entrances.  
 

Since our XY data is in latitude and longitude, we know that these coordinates are based on an 
unprojected, degree-based coordinate system. However, these numbers are each missing a decimal 
after the second digit, so we’ll have to fix this before continuing. 
 

7. Add two new fields called X and Y, with the type as Double for each. 
8. Right click on the column heading of X, and choose Field Calculator. Click Yes when asked if you 

want to edit outside of an edit session. Input this expression: 
[Longitude]/1000000 

Click Ok. 

9. Repeat this for Y, but using the Latitude field instead. Make sure the Xs are in the -70s and the 
Ys are in the 40s (otherwise your data would map in the wrong hemisphere). Close the table. 

10. Right click on the stations table (DBF) > Display XY Data 
11. Your X and Y should be automatically filled in for their respective fields. (Don’t click OK yet!) 

 
At this point you need to specify the coordinate system. As noted above, we already know that the data 
uses an unprojected coordinate system. We did not find metadata specifying which datum to use, but 
since we are in North America we will guess the North American Datum NAD83 was used. (Another 
common datum, especially for data outside North America is the World Geodetic System WGS84).  
 
The data frame was automatically set to the coordinate system of the first data layer we brought into 
our project, which was: NAD_1983_StatePlane_New_York_Long_Island_FIPS_3104_Feet – a coordinate 
system with the world projected onto a flat surface. ArcGIS is guessing this subway file is in the same 
coordinate system, but we know that is wrong because we know this file is using latitude longitude 
coordinates and is unprojected. 
 

12. Click on Edit  
13. Scroll up and expand Geographic Coordinate Systems > North America and select NAD 1983. 
14. Click OK > OK. 

 
You now have an on-the-fly point layer, but this is not yet its own shapefile. It also has a different 
coordinate system than the map document, which is less than ideal for analysis. (Having layers in 
different coordinate systems requires more calculations to run in the background, can decrease 
accuracy, and some tools won’t work.)  
 

15. Right click on the new point layer (stations Events) > Data > Export Data. Choose the radio 
button for Use the same coordinate system as the data frame. Click on the folder icon and save 
the export as subway_stations.shp in your folder on the desktop. Make sure Save as type is 
Shapefile.  

16. Click Save > Ok. When asked, select Yes that you want to add the new layer to the map. 
17. Remove the stations table and stationsEvents layer by right clicking and selecting Remove. 
18. Save your map document, especially if you haven’t done so recently. 

 
More information on displaying coordinate data and understanding map projections can be found 
through the GIS Services Website under Learn GIS > Tutorials and Help Resources:  
http://libguides.mit.edu/content.php?pid=347508&sid=2844938 

http://libguides.mit.edu/content.php?pid=347508&sid=2844938
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Modelbuilder and Clip, Buffer, and Intersect 
A clip analysis creates a new layer from the features of another layer 
that are completely inside a polygon feature. The next several steps 
are going to be performed in ModelBuilder, so you will only see the 
end result. 
 

1. In ArcToolbox ( ), right on the white space, and click Add Toolbox. (If you do not see 
ArcToolbox, click Geoprocessing > Arc Toolbox) Open the toolbox you created at the beginning 
of this exercise (Toolboxes > My Toolboxes > GIS Level 2.tbx). Alternatively you can drag your 
toolbox from ArcCatalog to ArcToolbox. 

2. Expand GIS Level 2, right click on the GIS Level 2 model, and 
click Edit. 
 

The model is now in edit mode, and you can add tools and layers for 
analysis in a flowchart-style diagram. First, we want to clip all of our 
layers to Manhattan. 
 

3. In the ArcToolbox, navigate to the clip tool (Analysis Tools > 
Extract > Clip), but instead of opening the tool, drag it into 
your model window. 
 

A clip analysis is now added to your model accompanied by an output 
feature class. Notice, however, that both are white boxes. This means 
that the required parameters have not yet been set. 
 

4. Double click on the Clip box to edit the parameters. Your input features are the subway stations, 
and the clip features are the borough boundaries.  Because you have already set up a definition 
query to limit the borough boundaries to Manhattan, this query will automatically carry through 
to your clip result. Your output will only include subway stations located within Manhattan. 
 

Notice your default Output Feature Class location is going into a geodatabase in a different location 
from your workspace. Geodatabases offer more functionality than shapefiles, but they bring with them 
more complexity. They are also a proprietary format type and can be tied to a specific version of the 
ESRI software. You can read more about them online at: 
http://www.esri.com/software/arcgis/geodatabase/index.html.   
 
For today we will stick with using only shapefiles.  
 

5. Change the output to your folder on the desktop and use a feature class (or shapefile) as the 
output type. Name your file subway_stations_clip. Click Save > Ok. 
 

http://www.esri.com/software/arcgis/geodatabase/index.html
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As you can see, no clip layer was created, but the subway station and borough layers were added to the 
model, and the tools and layers have different colors. At this point, if you were to run the model, it 
would create a clipped subway stations layer and nothing else. ModelBuilder’s utility, however, is in 
running multiple tools in sequence, so we will continue. 
 

6. Drag in the Clip tool two more times and repeat the same steps to clip the zoning district (nyzd) 
and school district boundaries layers. You will probably want to make your model window 
larger. In the input and clip features drop-down menus, you can select layers that are already in 
your model window ( ). In this way, you can use the borough layer multiple times as a clip 
feature without adding it more than once to the window (see below). Name the output features 
nyzd_clip and school_districts_clip. 
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Buffer 
A buffer analysis creates a polygon feature based on a specified distance around an input feature. It is 
therefore useful for finding out what is around something. We want to perform a buffer analysis on the 
subway stations, as we want a site that is within 500 feet of a station entrance. 
 

1. Add the buffer tool (Analysis Tools > Proximity > Buffer) to the model window. 
2. Double click on the Buffer box to edit the parameters. Your input features are the clipped 

subway stations (subway_stations_clip). Change the output feature class to the folder on your 
desktop and name the file subway_stations_clip_buffer. The linear unit is 500 feet, and the 
dissolve type is ALL. This means that we don’t care about keeping individual features; we just 
want a shape to show what space is within 500 feet of a subway station entrance. For more 
description about parameter options click the show help button at the bottom of the dialog box.  

3. Click OK. 
The buffer output will be a polygon layer representing all space within 500 feet of a Manhattan subway 
station entrance (remember that the clip tool will have already run when this model is implemented). 
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Intersect 
An intersect analysis creates a layer based on where two or more features overlap. This will be the final 
step in the ModelBuilder process. The intended result is a layer describing the area in Manhattan that 
satisfies the following criteria: within 500 feet of a subway station entrance, NOT in School District 3, 
and zoned residential use. 
 

1. Add the intersect tool (Analysis Tools > Overlay > Intersect) to the model window. 
2. Double click on the Intersect box to edit the parameters. 
3. Your input features are the subway station buffers (subway_stations_clip_buffer), the clipped 

zoning layer (nyzd_clip), and the clipped school district layer (school_districts_clip).  
4. Also specify the output feature class to be named suitable_area.shp and saved in your working 

folder. Click OK. 
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The final output is the suitable area shapefile. Your model should look something like this: 
 

 

5.  Run the model (Model > Run). One by one, the steps will be 
completed. Click Close when the entire run is complete. 
 

Notice that nothing new is added to your map by default.  
6. Add the new suitable area layer to your map using the add data 

button. You can find it in the folder on your desktop. Turn all other 
layers off so you can see the result. 

7. Back in the ModelBuilder window, Click Model –> Export. Notice 
you can either export to a Python Script – which can be very useful 
for setting up a process to automatically run through multiple 
iterations. You can also export to graphic formats such as PNG, 
PDF, or JPG so you can include an image of your model in 
documentation, like in your thesis. We will not export the model 
right now. 

Dissolve 
A dissolve allows a user to collapse features based on an attribute or set of 
attributes. In this case, a new layer will be created, where extra borders in 
suitable_area are removed and an aggregated boundary file based on 
school district boundaries is created. 

1. Under the Geoprocessing menu, click Dissolve. 
2. The input field is your suitable area layer. 

Choosing dissolve field(s) creates a separate feature for each distinct entry. In this case, we will check 
SCHOOLDIST so that our output file retains a distinction between suitable areas that fall in different 
school districts. Leave the statistic field(s) blank. Create multipart features allows features to be created 
with parts that are non-adjacent. Make sure it is checked. 

3. Click the file folder to change the location the files saves to the folder on your desktop. Name 
the file suitable_area_dissolve. 
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4. Click OK. It might take a few seconds for the dissolve to complete. You can now remove the 
original suitable area layer and keep only the dissolved layer on your map. 

Select by Location and Select by Attributes 
ArcGIS can also select features based on their spatial location relative to another layer. In this way, we 
can select vacant parcels that are completely within our suitable area. 

1. Turn on the tax lot layer and move it above the dissolved suitable area layer. 
2. Click on Selection > Select by Location. 

a. Selection method: select features from 
b. Target layer(s): tax lots (SDE_DATA.S_NY_NYC_MN_G47TXLOTS_2011) 
c. Source layer: suitable_area_Dissolve 
d. Spatial selection method: Target layer(s) features are completely within the Source layer 

feature 
3. Click OK. Right click on the tax lots layer and click Open Attribute table. At the bottom of the 

table notice that 118 vacant tax lots are suitable for our apartment building so far. 
 

We have one more constraint to apply, and that is lot area. Our apartment building is going to take up a 
lot of space, so we need to select a parcel that is at least 10,000 square feet. Our tax lot layer already 
has an attribute called LOTAREA, expressed in square feet. 

4. At the top of the attribute table, click the Select by Attributes button ( ). 
5. Here, we want to select from the parcels we have selected from before, so the method should 

be “Select from current selection”. 
6. The expression should be: LOTAREA >= 10000. Click Apply and OK. Now there are only 4 

parcels to choose from which satisfy our criteria. Close the attribute table. 
 

Spatial Join  
 

We’d like to join the table information from the suitable areas with the tax lots, where the two files 

spatially intersect with each other. Use the Search button  to find the tool called Spatial Join. If you 
don’t see the search window click Windows > Search. 
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1. Open Spatial Join (The search tells us we could also find this tool in ArcToolbox in Analysis Tools. 
 

2. Enter the following criteria in the Spatial Join dialog box: 
Target features: sde_data.us_ny_nyc_mn_g47txlots_2011 
Join features:  suitable_area_Dissolve 
Output feature class: save to your folder on the desktop and name it 
taxlots_suitablearea_join.shp 
Uncheck “Keep All Target Features” 
Match Option: INTERSECT (you may need to scroll down to see this) 

 
3. Click OK 
4. Open the attribute table of taxlots_suitablearea_join.shp.  

 
Notice this file only contains the 4 records that were selected in from the taxlots data layer. If we had 
not done the selection process first our output file would include all records from the taxlots file.  
 
In addition to the many details that were in the tax lot file, we can now quickly also find out the school 
district where the tax lots are located. If we had instead run the spatial join with the undissolved 
suitable area shapefile as the join feature, we would see more information, such as the zoning district 
for each of the parcels. 

Create and Edit Features 
ArcGIS also allows the creation and editing of shapefiles. In this section, we’re going to create a new 
layer for the building footprint of our potential apartment complex. 

1. Choose one of the suitable lots that you want to use for your apartment building and zoom in 
close to it.  
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2. Bring imagery into your map by clicking on the down arrow next to the Add Data button. Then 
click Add Basemap… 

 
 

3. Click Imagery. Click Add. 
4. Make your tax lot layer translucent. This can be done by right clicking on the layer and selecting 

Properties > Display. Change Transparent to something around 50%. Click Ok. 

 

5. If the location you have chosen is unsuitable (one of them is over a football field), go back (right 
click taxlots_suitablearea_join and click zoom to layer) and choose another. 

Now we’re ready to create a new layer. This is done in ArcCatalog, but ArcGIS 10.2 has conveniently 
added an ArcCatalog window which you’ve already used to create your model. 

6. Navigate to your folder in ArcCatalog. Right click on your work folder > New > Shapefile. 
7. Choose a name for your new shapefile. 
8. Feature type is polygon, as we want to create a building 

footprint. 
9. The Coordinate System is the same as the other layers in our 

map. Click Edit. Click on the drop down menu next to the 
globe icon and select Import. Select the subway stations layer 
to import your projection from. The window should have the 
State Plane coordinate system for Long Island with units in 
Feet. Click OK > OK. 

Add the layer to your map if it isn’t added automatically. There are 
currently no features in the layer. Accordingly, the attribute table of 
your buildings layer is blank, with the exception of a few fields that 
ArcGIS adds by default and generates automatically for features. 
We’re going to create features for this layer using the Editor toolbar. 
 

1. Open the Editor toolbar ( ) or click Customize -> Toolbars and turn on the Editor toolbar 
2. Click Editor > Start Editing.  
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3. Click on your building layer and click OK. The Create Features window should automatically 

open. If not, click on the create features button ( ) in the 
Editor toolbar. 

4. Click on your buildings layer. At the bottom of this window 
are some options. The default option is Polygon, with which 
you can create a polygon by defining its vertices. One by one, 
click on the map where you want the corners of your building. 

5. After you’ve finished the last corner, either double click or 
press F2 to finish the sketch. 

6. Save your edits (Editor > Save Edits) and stop editing (Editor > 
Stop Editing). 

Save your ArcMap Project and package it  
1. Save your ArcMap Document (.mxd). Click File -> Save 

 
When you save an ArcMap document, only the link to the layers is saved, not the layers themselves. If 
you will be sharing your maps or accessing them from another location, you can save your map 
document as a map package.  
 
A map package contains a map document (.mxd) and the data referenced by the layers it contains, 
packaged into one convenient, portable file. Map packages can be used for easy sharing of maps 
between colleagues in a work group, across departments in an organization, or with any other ArcGIS 
users via ArcGIS online. Map packages have other uses, too, such as the ability to create an archive of a 
particular map that contains a snapshot of the current state of the data used in the map.  

1. Click File > Share as > Map Package on the main menu.  
2. Select Save Package to file and select your folder on the desktop. Name your new map package.  
3. Click on Item Description and enter a summary, tags, and description. These fields can be used 

to communicate information with whoever you are sharing with so they know how the map was 
created, where you obtained the data, etc. 

4. Click Analyze to analyze your map for any errors or issues. You must analyze before you can 
save it to disk or share it to ArcGIS online. If any issues are discovered, a Prepare window will 
appear with a list of issues. Right-click on each Prepare message to get more information, read 
help for the error, and to click on suggested fixes.  

5. Once analyzed, the Share button will be enabled. Click Share to create your map package.  

Optional bonus exercises:  

Geocoding with QGIS 
We have a Iist of addresses of other job sites that we can geocode to see their proximity to our 
proposed apartment building. You can geocode using a file from ESRI Data & Maps (available in the GIS 
lab and online on the same IS&T web site from which you can download ArcMap).  Instructions for 
geocoding using ArcMap are available here:  http://libraries.mit.edu/files/gis/geocoding.pdf 
However, for the purposes of this exercise we will be using QGIS, an open source alternative to ArcGIS, 
to geocode. 
 
 

http://libraries.mit.edu/files/gis/geocoding.pdf
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Here is a brief rundown of the main differences between using ArcGIS and QGIS for geocoding. 

 QGIS Geocoding 
o QGIS is free and has the advantage of being able to tap directly into Google or 

OpenStreetMap geocoding APIs, and does not require an association with MIT or ESRI. 
o Note that Google limits the number of addresses that can be geocoded for free (2,500 

per day). There is no limit for OpenStreetMap. 
o Google and OpenStreetMap geocoding in QGIS can be used for addresses around the 

world, though accuracy may vary. 
o Easy to use, and relatively fast for small numbers of addresses. It can be slow for 

medium to large (>1,000) numbers of addresses. 

 ESRI Geocoding 
o ESRI’s geocoding service has many more customization options, and allows you the 

opportunity to interactively review and rematch address locations. 
o ESRI’s geocoding service is also much faster for large numbers of addresses. 
o ESRI geocoding is only available if you have access to a license of ArcGIS (i.e. active 

students, faculty, and staff at MIT)  
o At MIT, ESRI’s geocoding service is only available for the United States and Canada. 

 
1. Using the Windows Start Menu, navigate to All Programs QGIS QGIS Desktop 

2. Install and activate the MMQGIS Plugin by navigating to Plugins Manage and Install Plugins, 

and selecting and installing mmqgis. Then close the Plugins window. 

3. Navigate to MMQGIS GeocodeGeocode CSV with Google / OpenStreetMap. For your input 

CSV file, browse and select current_projects.csv from your data folder. Note that any table you 

want to geocode must be in .csv format. Select an address field, city field, state field and country 

field using the drop down menu. QGIS may do this automatically, but make sure it has selected 

the correct fields. Select Google Maps as your Web Service. Choose your working folder as the 

location for your output shapefile and not found output list.  Press OK. 

4. Once complete, QGIS tells you at the bottom of the screen how many addresses were matched, 

and the geocoded addresses should have been automatically added to your map.  Close out of 

QGIS without saving your project.  

5. Back in your ArcMap document, you can add your newly generated geocoded shapefile to your 

existing map. 

Resources 
 MIT GIS Services: http://libguides.mit.edu/gis 

 NYC Department of City Planning: nyc.gov/html/dcp/home.html 

o BYTES of the BIG APPLE: nyc.gov/html/dcp/html/bytes/applbyte.shtml 

 MTA Developer Resources: mta.info/developers/download.html 

 

http://libguides.mit.edu/gis
http://www.nyc.gov/html/dcp/home.html
http://www.nyc.gov/html/dcp/html/bytes/applbyte.shtml
http://mta.info/developers/download.html
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