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Introduction to GIS using QGIS 2.10.1 
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Introduction 
The purpose of this tutorial is to introduce you to the use of QGIS functions. Each lesson is designed to instruct 

you in one or more of these functions. If you are unfamiliar with geographic information systems (GIS), one 

resource you can review is the Guide to Geographic Information Systems (http://www.gis.com/). A full user 

guide to QGIS is located under the QGIS help menu and can also be accessed here: 

http://www.qgis.org/en/docs/index.html 

Adding Layers and Basemaps 
1. Go to MassGIS (http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-

serv/office-of-geographic-information-massgis/datalayers/census2010.html) to download the US Census 

(2010) municipalities shapefile (located under the “Other Geography” section of the page).  

 
 

2. Also download the USGS hydrography shapefile from MassGIS (http://www.mass.gov/anf/research-and-

tech/it-serv-and-support/application-serv/office-of-geographic-information-

massgis/datalayers/hd100.html).  

3. Extract (unzip) both sets of data into a working folder on your machine by right clicking. 

4. Start QGIS by going to Start > All Programs > QGIS Pisa > QGIS Desktop 2.10.1 

http://www.gis.com/
http://www.qgis.org/en/docs/index.html
http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-of-geographic-information-massgis/datalayers/census2010.html
http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-of-geographic-information-massgis/datalayers/census2010.html
http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-of-geographic-information-massgis/datalayers/hd100.html
http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-of-geographic-information-massgis/datalayers/hd100.html
http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-of-geographic-information-massgis/datalayers/hd100.html
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5. Click on the Add Vector Layer button ( ), click Browse, and navigate to the folder where you stored 

the data. Be careful not to click on the Add Grass Vector Layer, Add WFS layer, or New Shapefile 

buttons, which look similar. The button may be at the top of the screen on along the left side. Add the 

polygon municipalities layer (CENSUS2010TOWNS_POLY.shp) and hydrology layer 

(HYDRO100K_POLY.shp) to your map. 

Note: you may use the Ctrl or Shift keys to select more than one layer at a time. The Ctrl key allows you to select 

specific individual layers; the Shift key allows you to highlight a range of layers. 

6. Add an imagery base layer by clicking on Web > OpenLayers plugin. Choose Bing Maps > Bing Aerial. 

Important: If you do not see the OpenLayers plugin, click Plugins at the top of the screen and select 
Manage and Install Plugins. Select OpenLayers from the list of plugins. Click Install Plugin and close the 
window. Then you will be able to add imagery to the map as described above. 
 

You may have to drag the aerial imagery below the other layers so it does not cover them.  

 
Change the map projection to match that of the imagery so that it better lines up with the other data layers. 

7. Click Project > Project Properties > CRS 

8. In the filter search for “Pseudo Mercator”. Select this projection in the Coordinate Reference Systems 

box and click OK. 

9. Turn the three layers off and on by checking the small box to the left of the name of each layer in 

the Layers Window. If you still cannot see a layer in the window, right click the layer name and go 

to Zoom to Layer. 

10. Save your QGIS project file. In the Project menu click Save As. Choose a name and save it to the same 

directory where your map data is located 

A QGIS Project file is a record of the layers that have been added to a map display, along with the map display 
itself. This allows users to recover a map display including the layers in the map, symbolization, visibility, units of 
measurement, and other display settings. We recommend saving frequently with any GIS software. 

The Toolbar 

 

1. Look at the QGIS Toolbar. The toolbars can be moved so they may be displaying along the side or across 

the top. Move your mouse over each tool icon. Notice that the software will indicate the name of each 

tool. 
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2. Click on the Zoom In button ( ). You will notice that your cursor turns into a magnifying glass with a 

plus sign (+) inside the glass. Click and hold your left mouse button and drag the cursor to create a 

translucent box on the map. If you release the left mouse button the Map View will zoom to that area. 

3. Click on the Zoom Out button ( ). The cursor will turn into a magnifying glass with a minus sign (-) 

inside the glass. Move the magnifying glass over the map. Click your left mouse button once to zoom 

out. 

4. Zoom Full ( ) will zoom to the full extent of all the layers in the map. Test this button with the aerial 

imagery turned off. 

5. Pan Map ( ) drags the Map View in any direction. There are also buttons to zoom to your previous or 

next extents. ( ) 

6. If you want more screen real estate, you can turn the Layers window off. Choose View > Panels and 

click Layers. For now, keep the Layers Window on. 

Changing Names of Layers, Layer Colors, and Labeling  
The layer properties dialog box enables one to change a variety of display properties for each layer, including 

symbology and labeling. There are two ways you can get to the layer properties dialog box: 1) right click the 

layer name then click properties, or 2) double click the layer name or icon. 

1. Open the layer properties box for the HYDRO100K_POLY layer. 

2. Under the General tab, change the layer name of HYDRO100K_POLY to “water” 

 

3. Switch to the Style Tab. Click on “Simple Fill” in the box on the left. Adjust the symbol layer type so that 

the fill color is blue and the border style is “No Pen”. 
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Within the Style tab, note that it is possible to adjust the layer’s transparency. Increasing the layer transparency 

allows features located behind that layer to be seen.  For now, you can leave the water layer’s transparency at 

0%. 

4. Click OK. 

QGIS provides the capability to label features based on a user-specified text field from the layers database.  

5. Right click on the CENSUS2010TOWNS_POLY layer and click properties to display the layer properties 

menu.  

6. Click on the Labels tab. Put a checkmark in the box “Label this layer with” and select the TOWN column 

from the drop down menu.  

7. Click OK. 

 

Making a Layer Active and Exploring the Data  
 
An active layer is one whose attribute information is available to the user and one on which the user can 
perform some operation. For example, a user can identify attributes of the layer or change its symbology. An 
active layer appears to be highlighted; all you have to do is click on the layer in the Layers Window. 

The Identify tool ( ) is used to quickly retrieve attribute information for a feature on a map. In order to use 
this tool for a specific map layer, the layer that contains the information must be made active, then the features 
of the layer on the map can be clicked to obtain information about each feature. One of the benefits of GIS is 
that, in addition to being able to display a map of a layer, one can also display attributes about a layer that are 
stored in a database.  
 

1. Click on the CENSUS2010TOWNS_POLY layer. 

2. Test the identify tool by clicking on various towns throughout the map. The results will appear in an 

“Identify Results” panel at the left. 
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3. Click the “Clear Results” button  and close the “Identify Results” window when you are done. 

4. Right click on the CENSUS2010TOWNS_POLY layer, then click the Open Attribute Table button ( ). 

Notice that there is a row for each town and columns with data such as town name, population values, 

and population change. More descriptive information about this data can be found in the metadata that 

was downloaded with the file and on the MassGIS website (http://www.mass.gov/anf/research-and-

tech/it-serv-and-support/application-serv/office-of-geographic-information-

massgis/datalayers/census2010.html) where you downloaded the data.  

5. Select rows by clicking on the row ID at the far left of each row. Select several of the polygons 

representing Massachusetts towns. Holding the Ctrl key will allow you to select more than one feature. 

When a record is selected on the map or in the table it changes color so it is distinguishable from the non-

selected records. Also notice a set of helpful tools in the top of the attribute table dialog box which offer options 

such as move selection to the top or invert the selection. The box at the bottom of the attribute table lets you 

show all features or only selected ones.  

6. Close the attribute table, and clear your selections by clicking on the Deselect Features from all Layers (

) button. 

 

Using the Query Builder  
The query builder tool enables you to identify map features that meet a certain criterion or criteria. For 

example, suppose you were working with a map of the United States and wanted to find all cities with a 

population of 1 million people or greater. 

1. Right click the CENSUS2010TOWNS_POLY layer and select Properties. 

2. In the General tab, click on Query Builder (under Feature subset – you may need to scroll down). 

http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-of-geographic-information-massgis/datalayers/census2010.html
http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-of-geographic-information-massgis/datalayers/census2010.html
http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-of-geographic-information-massgis/datalayers/census2010.html
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3. Choose the POPCH90_00 field by double clicking on it and select “<” as the operator for your query by 

clicking on it. Type in “0” complete your filter expression. 

4. Click Test and note there are 60 matching features (i.e. 60 towns with a shrinking population between 

the 1990 and 2000 census).  

5. Click Ok and expand the query to: POPCH90_00 < 0 AND POPCH00_10 < 0 

6. Click Test and note there are 24 matching features (i.e. 24 towns with both decades of shrinking 

population between 1990 and 2010). Click OK to exit the query builder and properties menu.  

 

7. Open the attribute table to easily distinguish which towns have been shrinking. Only features that meet 

the query criteria will be shown. 

 

8. Close the attribute table.  
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9. Right click on the CENSUS2010TOWNS_Poly layer name and click “Save As”. Click the Browse button to 

save the layer as “Towns_PopLoss” within your working folder. Leave all other default save options 

unchanged and press OK to save the layer.  

10. If the layer does not get added to your map automatically, use the Add Vector Data ( ) button to do 

so yourself.  

11. Open the layer properties and query builder of the original CENSUS2010TOWNS_POLY layer and clear 

the query builder. Close the layer properties. 

 

You should now have two town layers—one only symbolizing municipalities experiencing population 

loss, and the other symbolizing all municipalities.  

 

After you’ve completed this step, you can uncheck the new Towns_PopLoss layer within the layers menu. 

Changing Layer Properties, Symbolizing Data, and Creating/Editing Data 
There are three primary symbology renderers 

in the Legend Type drop down box that allow 

you to choose between various symbolization 

options: Single Symbol, Graduated, and 

Categorized. We will use graduated symbol to 

look at the population change between the 

2000 and 2010 census in the state of 

Massachusetts by town.  

1. Right click and open the layer 

properties dialog box for 

CENSUS2010TOWNS_POLY, and go to 

the Style tab. 

2. In the Style tab, change the style to 

Graduated in the drop-down menu in 

the top left. 
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3. Select POPCH00_10 as the column. 

4. Choose Equal Interval as the mode (an equal number of features/rows will be assigned to each class) 

with five classes (or “breaks”). Click Classify and then click apply. 

5. Change the mode from Equal Interval to Quantiles, then OK. 

  

Notice the map looks totally different. Small changes can be very influential in people’s interpretations of maps. 

A graduated classification produces a choropleth map, which is one of the most common forms of maps used 

today. The word choropleth derives from two Greek root words, “choros” meaning place, and “plethos” 

meaning value. A choropleth, or place value map, displays each area on the map by shading or coloring the areas 

based on their values. In particular, the values are grouped according to a classification system, and then a 

shade or color is applied to each value based on grouping of values. Shades or colors are usually graduated from 

light to dark with dark meaning more of the value and light meaning less of the value. 

Creating New GIS data 
We will create polygons to represent buildings by tracing (“digitizing”) from the aerial imagery. 

1. Check the aerial imagery layer if it is not visible already. 

2. Uncheck the CENSUS2010TOWNS_POLY layer so you can 

see the imagery. 

3. Zoom in close to an area of your choosing until you can 

clearly make out individual buildings. 

4. Click the New Shapefile Layer button ( ). Select polygon 

as the type and add a text attribute for building names 

abbreviated as bldgname. Make sure to click “Add to 

attributes list”. 

5. Press OK. Save the new file as “buildings” to your working 

directory. 

6. Move the buildings layer to the top of your list of layers. 

7. Click the toggle editing button ( ). 

8. Click the Add Feature button ( ). 

9. Click on the buildings layer to select it. 
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10. Left click on each of the corners (vertices) of a building and then right click anywhere on the map to 

finalize the polygon (right clicking does not create a new vertex). You will be prompted to fill out the 

attribute table for your new polygon, so enter a name for the building. 

11. Click the save layer edits button ( ) to save your new building. Toggle out of edit mode by clicking 

the toggle editing button again. 

Map Units, Scale, and Coordinates 
1. Look down at the bottom of the screen at the Status Bar. You will see an X/Y coordinate and a scale. The 

map units must be set in order for the scale of the map in the Map View to be indicated. 

2. To see what the map units are, or to set them, click Project > Project Properties > General Tab and make 

sure the canvas units are set to “Meters”, and click OK.  

Notice that the scale bar on your map is metric. Every GIS dataset should have map units stored within it. If the 

software does not automatically include the units, check the metadata to find out what they are and set them 

manually in the QGIS project. If no map units are specified, an Incorrect Measure Results box pop-ups and tells 

you where to fix the coordinates. 

Printing a Map and Saving as a Graphics File 
1. Uncheck your imagery and buildings layer check the towns layer you were working on earlier. Zoom to 

the full extent of the towns layer. You can save the map as you see it as an image file. Click Project > 

Save as Image 

 

A dialog box will appear where you should specify the name of your file and save it with your other work. There 

are many formats to choose from. JPEG and PNG are widely supported formats that are easy to insert into text 

documents and presentations. Or you can create a more meaningful map by adding the components important 

for understanding it, such as a title, legend, scale bar, North arrow, data sources, date created, and any other 

notes. You can do all these things using Composer. 

2. Click Project > New Print Composer. Give your composer a name. 
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3. On the right under the Composition tab you can specify things like page size and orientation. Choose 

landscape in this case. 

4. To add the QGIS map canvas, click on the Add new map from QGIS map canvas button ( ) in the print 

composer toolbar (this toolbar may be at the top or left of the window). 

5. Click and drag a rectangle on the composer canvas with the left mouse button to add the map. 

6. Click on the Add new label button ( ), and click inside the map to insert a title. In the Item Properties 

Tab (on the right), type the name of your map, adjust the font, and the alignment. Scroll down to see 

additional options where you can also adjust the frame color, position and size. 

7. Click on the Add Image button, ( ) and draw a rectangle inside the map. In the Item Properties Tab 

expand Search directories and scroll down until you find a North Arrow and select it. You can adjust its 

size within the map. Uncheck “background” to remove the white space around the arrow. 

8. Press the Add new scalebar button ( ). Click and drag to draw a scale box. In the Item properties tab 

you can adjust what type of scale you want. 

9. Click the Add new legend button ( ) and click and drag to place a legend. In the Item properties tab 

you can customize the legend title and update which layers are to be included in the legend. 

10. You can save your map in a variety of different formats. To do so, choose one of the following buttons at 

the top of the window:  (various image formats, .svg, and .pdf, respectively). An example of 

what your map could look like (without much work on its cartographic design) is below. 

 

 Have fun with QGIS! Continue on to the next page if you are looking for some additional challenges. 
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Bonus Challenges: Exploring Tools in QGIS and Modifying an Attribute Table 
 

Introduction to QGIS Tools and Functions 

If you are looking to analyze geospatial data in any way, you will most likely use GIS tools to manipulate and 

analyze spatial data. We explore some of these tools in GIS Level 2 (our intermediate GIS workshop) but here is a 

quick preview. 

1. Close the print composer window and return to your project. 

2. Download MBTA rapid transit data from MassGIS:  http://www.mass.gov/anf/research-and-tech/it-serv-

and-support/application-serv/office-of-geographic-information-massgis/datalayers/mbta.html  

3. Extract the data into your working folder and add MBTA_NODE.shp to your map (this data represents 

MBTA rapid transit station locations on the Green, Red, Orange, Blue, and Silver Lines. 

Earlier in this exercise, you learned how to select and extract features that met certain attribute criteria. For 

example, you should easily be able to extract just the MBTA Red Line stations from this larger MBTA rapid 

transit node dataset. However, what if you wanted to select features from one layer based on their location 

in another layer? For example, how would you select just the MBTA stations located within the City of 

Cambridge? 

4. On your map, use the Select Features button to select Cambridge. You may need to zoom in to make the 

selection. 

5. Click Vector Research Select Layers by Location 

6. Select features in MBTA_NODE that intersect CENSUS2010TOWNS_POLY. Make sure you check the 

“Only selected features” box to limit your selection to MBTA nodes within Cambridge. Press OK to close 

the box.  

7. It might be difficult to see if your select by location worked until you open your MBTA_NODE attribute 

table. Once opened, note the text at the top of the attribute table notes there are 162 features total and 

six are selected. Browsing through your attribute table you should see Harvard, Kendall/MIT, Lechmere, 

Alewife, Porter, and Central highlighted. If you wish, you could export this selection to a new shapefile 

by right clicking on MBTA_NODE and clicking Save As. 

8. Clear your selections. 

If you are feeling brave, feel free to experiment with some of the other tools within QGIS. Most of the 

common GIS processing tools are located  under VectorGeoprocessing. 

Editing an Attribute Table  

Earlier, you learned how to add your own features (traced building outlines) to a map, but what if you need to 

return to your buildings layer and edit some of its attribute information or add/delete columns? 

 You can edit inside the full table attribute table following these steps: 

o Right click on the layer name in the Layers list and select “Open Attribute Table”  

http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-of-geographic-information-massgis/datalayers/mbta.html
http://www.mass.gov/anf/research-and-tech/it-serv-and-support/application-serv/office-of-geographic-information-massgis/datalayers/mbta.html
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o Toggle editing mode by clicking on the pencil  This button shows up both in the main QGIS 

toolbar and the toolbar within the attribute table. 

o This activates the “Delete column”, “New column” and “Open field calculator” buttons within 

the attribute table toolbar:   

o You will also now be able to edit text within any of the existing fields in the attribute table. 

o Once done editing, toggle editing mode off. You will be prompted to save your edits unless you 

already clicked on the “Save edits” button. 

 You can also edit attributes outside the full attribute table, one feature at a time. 

o Identify  a particular feature you are interested in editing. 

o An “Identify Results” box should pop up with the attribute data for that feature. 

o As long as your editing button is toggled on, you should be able to select the “Edit Feature 

Form” button  

o That should pop up a window where you can edit attributes for that particular feature. 

 The field calculator can be used to create new fields from existing data in the attribute table. For 

example, if you wanted to symbolize towns from the CENSUS2010TOWNS_POLY shapefile based on 

population change between 1970 and 2010, you would have to use the field calculator to determine 

each town’s population change (since those values do not already exist in the attribute table). 

o Open the CENSUS2010TOWNS_POLY attribute table. 

o Click on the Field calculator  

o Check the box for create a new field, name it “POPCH70_10” and select whole number (integer) 

as the output field type. 

o In the function list, scroll down to Field and Values and double click on POP2010. Then click on 

the “-” under Operators, and double click on POP1970 back in the Fields and Values list. This 

expression will give the population change between 1970 and 2010 by town. 

o Feel free to symbolize your map based on the data in the new column if you wish. 

 

For more information, check out the QGIS User Guide: 

http://docs.qgis.org/2.10/en/docs/user_manual/index.html 

 

http://docs.qgis.org/2.10/en/docs/user_manual/index.html
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